re = /^[ آابپتثجچحخدذرزژسشصضطظعغفقکگلمنوهی]+$/m
str = 'سلام
خوبی
سلام څوبی
لاعب كرة قدم قطري يلعب حالياً'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end