using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TABLEXY1(\(([^()]|(?1))*\))";
string input = @"TABLEXY1((INITIALPARAM2*117.3/MADAD(2)),INITIALPARAM1+1)*PARAM2/100*(TABLE12(INITIALPARAM3)*PARAM3-(TABLE12(INITIALPARAM4)*PARAM4)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}