re = /TABLEXY1(\(([^()]|(?1))*\))/
str = 'TABLEXY1((INITIALPARAM2*117.3/MADAD(2)),INITIALPARAM1+1)*PARAM2/100*(TABLE12(INITIALPARAM3)*PARAM3-(TABLE12(INITIALPARAM4)*PARAM4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end