package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`TABLEXY1(\(([^()]|(?1))*\))`)
var str = `TABLEXY1((INITIALPARAM2*117.3/MADAD(2)),INITIALPARAM1+1)*PARAM2/100*(TABLE12(INITIALPARAM3)*PARAM3-(TABLE12(INITIALPARAM4)*PARAM4)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}