package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^/?users/(?P<user_id>[0-9a-f]{32})/$`)
var str = `/users/be00e546822945bbb193b4ed80149c35/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}