$re = '/^/?users/(?P<user_id>[0-9a-f]{32})/$/';
$str = '/users/be00e546822945bbb193b4ed80149c35/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);