re = /^\/?users\/(?P<user_id>[0-9a-f]{32})\/$/
str = '/users/be00e546822945bbb193b4ed80149c35/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end