#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?<amount>.*?\s*\b(?:tsp|teaspoon|packet|ounces|fl\.\s*ounces|fl\.\s*ounce|cup))\b\s*(?<val>.*)$"
Local $sString = "2 fl. ounces paprika" & @CRLF & _
"3/4 fl.ounce paprika" & @CRLF & _
"1 Chopped Tomato" & @CRLF & _
"1/2 Cup yogurt" & @CRLF & _
"unclear amount of whatever" & @CRLF & _
"1 packet pasta" & @CRLF & _
"½ tsp fine sea salt" & @CRLF & _
"3 sliced onions" & @CRLF & _
"1/2 teaspoon heavy cream" & @CRLF & _
"2 ounces paprika" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")