use strict;
my $str = '2 fl. ounces paprika
3/4 fl.ounce paprika
1 Chopped Tomato
1/2 Cup yogurt
unclear amount of whatever
1 packet pasta
½ tsp fine sea salt
3 sliced onions
1/2 teaspoon heavy cream
2 ounces paprika
';
my $regex = qr/^(?<amount>.*?\s*\b(?:tsp|teaspoon|packet|ounces|fl\.\s*ounces|fl\.\s*ounce|cup))\b\s*(?<val>.*)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}