# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<amount>.*?\s*\b(?:tsp|teaspoon|packet|ounces|fl\.\s*ounces|fl\.\s*ounce|cup))\b\s*(?<val>.*)$"
test_str = ("2 fl. ounces paprika\n"
"3/4 fl.ounce paprika\n"
"1 Chopped Tomato\n"
"1/2 Cup yogurt\n"
"unclear amount of whatever\n"
"1 packet pasta\n"
"½ tsp fine sea salt\n"
"3 sliced onions\n"
"1/2 teaspoon heavy cream\n"
"2 ounces paprika\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.