package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/|\/magento-2-pwa\/theme\/pwa-features\/|\/magento-2-pwa\/pwa-customization\/|\/magento-2-pwa\/theme\/|\/magento-2-pwa\/pwa-theme\.html`)
var str = `https://www.gomage.com/
https://stage.gomage.com/magento-2-pwa/theme/pwa-features/
https://stage.gomage.com/magento-2-pwa/pwa-customization/
https://stage.gomage.com/magento-2-pwa/theme/
https://www.gomage.com/magento-2-pwa/pwa-theme.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}