const regex = /^\/|\/magento-2-pwa\/theme\/pwa-features\/|\/magento-2-pwa\/pwa-customization\/|\/magento-2-pwa\/theme\/|\/magento-2-pwa\/pwa-theme\.html/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/|\\\/magento-2-pwa\\\/theme\\\/pwa-features\\\/|\\\/magento-2-pwa\\\/pwa-customization\\\/|\\\/magento-2-pwa\\\/theme\\\/|\\\/magento-2-pwa\\\/pwa-theme\\.html', 'gm')
const str = `https://www.gomage.com/
https://stage.gomage.com/magento-2-pwa/theme/pwa-features/
https://stage.gomage.com/magento-2-pwa/pwa-customization/
https://stage.gomage.com/magento-2-pwa/theme/
https://www.gomage.com/magento-2-pwa/pwa-theme.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}