re = /^\/|\/magento-2-pwa\/theme\/pwa-features\/|\/magento-2-pwa\/pwa-customization\/|\/magento-2-pwa\/theme\/|\/magento-2-pwa\/pwa-theme\.html/m
str = 'https://www.gomage.com/
https://stage.gomage.com/magento-2-pwa/theme/pwa-features/
https://stage.gomage.com/magento-2-pwa/pwa-customization/
https://stage.gomage.com/magento-2-pwa/theme/
https://www.gomage.com/magento-2-pwa/pwa-theme.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end