using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\A(*COMMIT).*?world)?.*?hello";
string input = @"blah blah blah
hello
blah blah blah
class=""world""
blah blah blah
hello
blah blah
hello
blah blah blah
hello
blah blah blah";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}