// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(?:\A(*COMMIT).*?world)?.*?hello").unwrap();
let string = "blah blah blah
hello
blah blah blah
class=\"world\"
blah blah blah
hello
blah blah
hello
blah blah blah
hello
blah blah blah";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}