re = /(?:\A(*COMMIT).*?world)?.*?hello/
str = 'blah blah blah
hello
blah blah blah
class="world"
blah blah blah
hello
blah blah
hello
blah blah blah
hello
blah blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end