#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([^<>()\[\]\.,;:\s@\"]+(\.[^<>()\[\]\.,;:\s@\"]+)*)|(\".+\"))@(([^<>()[\]\.,;:\s@\"]+\.)+[^<>()[\]\.,;:\s@\"]{2,})$"
Local $sString = "\u001\u002@autobots.com" & @CRLF & _
"msekhar@yahoo.com" & @CRLF & _
"msekhar@cs.aau.edu" & @CRLF & _
"ms.sekhar@yahoo.com" & @CRLF & _
"ms_sekhar@yahoo.com" & @CRLF & _
"msekhar@cs2.aau.edu" & @CRLF & _
"msekhar@autobots.ai" & @CRLF & _
"msekhar@interior.homeland1.myanmar.mm" & @CRLF & _
"msekhar1922@yahoo.com" & @CRLF & _
"msekhar#21@autobots.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")