import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([^<>()\\[\\]\\.,;:\\s@\\\"]+(\\.[^<>()\\[\\]\\.,;:\\s@\\\"]+)*)|(\\\".+\\\"))@(([^<>()[\\]\\.,;:\\s@\\\"]+\\.)+[^<>()[\\]\\.,;:\\s@\\\"]{2,})$";
final String string = "\\u001\\u002@autobots.com\n"
+ "msekhar@yahoo.com\n"
+ "msekhar@cs.aau.edu\n"
+ "ms.sekhar@yahoo.com\n"
+ "ms_sekhar@yahoo.com\n"
+ "msekhar@cs2.aau.edu\n"
+ "msekhar@autobots.ai\n"
+ "msekhar@interior.homeland1.myanmar.mm\n"
+ "msekhar1922@yahoo.com\n"
+ "msekhar#21@autobots.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}