package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([^<>()\[\]\.,;:\s@\"]+(\.[^<>()\[\]\.,;:\s@\"]+)*)|(\".+\"))@(([^<>()[\]\.,;:\s@\"]+\.)+[^<>()[\]\.,;:\s@\"]{2,})$`)
var str = `\u001\u002@autobots.com
msekhar@yahoo.com
msekhar@cs.aau.edu
ms.sekhar@yahoo.com
ms_sekhar@yahoo.com
msekhar@cs2.aau.edu
msekhar@autobots.ai
msekhar@interior.homeland1.myanmar.mm
msekhar1922@yahoo.com
msekhar#21@autobots.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}