using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{([A-Za-z]*)([\s\S]((\\:)|[^:])*?)([\s\S]((\\:)|[^:])*?)}";
string input = @"{Time:\d+\:\d+\:\d+:hh\\:mm\\:ss}
{Time:\d+\:\d+\:\d+}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}