$re = '/{([A-Za-z]*)([\s\S]((\\\\:)|[^:])*?)([\s\S]((\\\\:)|[^:])*?)}/';
$str = '{Time:\\d+\\:\\d+\\:\\d+:hh\\\\:mm\\\\:ss}
{Time:\\d+\\:\\d+\\:\\d+}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);