package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{([A-Za-z]*)([\s\S]((\\:)|[^:])*?)([\s\S]((\\:)|[^:])*?)}`)
var str = `{Time:\d+\:\d+\:\d+:hh\\:mm\\:ss}
{Time:\d+\:\d+\:\d+}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}