#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<script.*?>[\s\S]*?<\/script>"
Local $sString = "<script>alert(document.cookie);</script>" & @CRLF & _
"<script>alert(document.cookie);</script><script>alert(document.cookie);</script>" & @CRLF & _
"<script>" & @CRLF & _
"if(true===false){" & @CRLF & _
"}" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")