#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(_D-0[1-7]_hot(43|50)|_D-0[8,9]_hot56|_D-1[0,1]_hot56)"
Local $sString = "MFTF2LH_LSetC1_D-05_cold_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-08_hot43_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-09_hot43_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-10_hot43_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-11_hot43_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-08_hot50_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-09_hot50_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-10_hot50_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-11_hot50_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-01_hot56_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-02_hot56_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-03_hot56_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-04_hot56_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-05_hot56_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-06_hot56_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-07_hot56_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-07_cold_fa00_bpmin" & @CRLF & _
"MFTF2LH_LSetC1_D-08_cold_fa00_bpmin" & @CRLF & _
"MFTF2LH_LSetC1_D-09_cold_fa00_bpmin" & @CRLF & _
"" & @CRLF & _
"MFTF2LH_LSetC1_D-04_hot50_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-07_hot43_fa00_bpmax" & @CRLF & _
"MFTF2LH_LSetC1_D-10_hot56_fa00_bpmax"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")