import re
regex = re.compile(r"(_D-0[1-7]_hot(43|50)|_D-0[8,9]_hot56|_D-1[0,1]_hot56)")
test_str = ("MFTF2LH_LSetC1_D-05_cold_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-08_hot43_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-09_hot43_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-10_hot43_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-11_hot43_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-08_hot50_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-09_hot50_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-10_hot50_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-11_hot50_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-01_hot56_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-02_hot56_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-03_hot56_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-04_hot56_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-05_hot56_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-06_hot56_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-07_hot56_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-07_cold_fa00_bpmin\n"
"MFTF2LH_LSetC1_D-08_cold_fa00_bpmin\n"
"MFTF2LH_LSetC1_D-09_cold_fa00_bpmin\n\n"
"MFTF2LH_LSetC1_D-04_hot50_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-07_hot43_fa00_bpmax\n"
"MFTF2LH_LSetC1_D-10_hot56_fa00_bpmax")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")