import re
regex = re.compile(r".*?{\"EVENT_NAME\":\"(?<tag6>[^\"]*)\",\"EVENT_ID\":\"(?<action>[^\"]*)\",\"User_Id\":\"(?<login>[^\"]*)\",\"X_Corelation_ID\":\"(?<policy>[^\"]*)\",\"Client_IPAddress\":\"(?<sip>[^\"]*)\",\"Acting_As_ID\":\"(?<account>[^\"]*)\",\"Message\":\"(?<tag2>[^\"]*)\"}", flags=re.MULTILINE)
test_str = ("[2019-01-15 13:44:43,432] [[ACTIVE] ExecuteThread: '45' for queue: 'weblogic.kernel.Default (self-tuning)'] WARN SiemLogger - {\"EVENT_NAME\":\"SIEM\",\"EVENT_ID\":\"LOGOUT\",\"User_Id\":\"ROBKNT1810\",\"X_Corelation_ID\":\"null\",\"Client_IPAddress\":\"null\",\"Acting_As_ID\":\"null\",\"Message\":\"MobileSignOutPage - User successfully logged out.\"}\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")