#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{4}-\d{2}-\d{2}.*?\{[^}]*"status": 4\d{2}.*\}"
Local $sString = "2024-06-24T05:05:26.31412196Z stdout F {"time": "2024-06-24T05:05:26+00:00", "remote_addr": "-", "x_forwarded_for": "XX.XX.XX.XX, XX.XX.XX.XX", "request_id": "xxxxxxxxxxxxxxxxxxxx","remote_user": "-", "bytes_sent": 833, "request_time": 0.120, *"status": 401*, "vhost": "xxxxxxxxxxxxxxx.com", "request_proto": "HTTP/1.1","path": "/xxxxx/xxxxxxxxx", "request_query": "-", "request_length": 550, "duration": 0.120,"method": "POST", "http_referrer": "-","http_user_agent": "okhttp/4.9.2", "upstream_cache_status": "-" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")