$re = '/\d{4}-\d{2}-\d{2}.*?\{[^}]*"status": 4\d{2}.*\}/m';
$str = '2024-06-24T05:05:26.31412196Z stdout F {"time": "2024-06-24T05:05:26+00:00", "remote_addr": "-", "x_forwarded_for": "XX.XX.XX.XX, XX.XX.XX.XX", "request_id": "xxxxxxxxxxxxxxxxxxxx","remote_user": "-", "bytes_sent": 833, "request_time": 0.120, *"status": 401*, "vhost": "xxxxxxxxxxxxxxx.com", "request_proto": "HTTP/1.1","path": "/xxxxx/xxxxxxxxx", "request_query": "-", "request_length": 550, "duration": 0.120,"method": "POST", "http_referrer": "-","http_user_agent": "okhttp/4.9.2", "upstream_cache_status": "-" }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);