import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}-\\d{2}-\\d{2}.*?\\{[^\\}]*\"status\": 4\\d{2}.*\\}";
final String string = "2024-06-24T05:05:26.31412196Z stdout F {\"time\": \"2024-06-24T05:05:26+00:00\", \"remote_addr\": \"-\", \"x_forwarded_for\": \"XX.XX.XX.XX, XX.XX.XX.XX\", \"request_id\": \"xxxxxxxxxxxxxxxxxxxx\",\"remote_user\": \"-\", \"bytes_sent\": 833, \"request_time\": 0.120, *\"status\": 401*, \"vhost\": \"xxxxxxxxxxxxxxx.com\", \"request_proto\": \"HTTP/1.1\",\"path\": \"/xxxxx/xxxxxxxxx\", \"request_query\": \"-\", \"request_length\": 550, \"duration\": 0.120,\"method\": \"POST\", \"http_referrer\": \"-\",\"http_user_agent\": \"okhttp/4.9.2\", \"upstream_cache_status\": \"-\" }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}