using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|{2,}|&{2,}|((?:(?!&&|\|\||\bcontains\b).)*) (contains) ((?:(?!&&|\|\||\bcontains\b).)*)";
string input = @"'oil & blah'blah' contains 'oil&blah'blah' && 'oil & blah'blah' contains 'oil blah's'
'oil & blah'blah' contains 'oil&blah'blah'||||||||||'oil & blah'blah' contains 'oil blah's' ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}