re = /\|{2,}|&{2,}|((?:(?!&&|\|\||\bcontains\b).)*) (contains) ((?:(?!&&|\|\||\bcontains\b).)*)/m
str = '\'oil & blah\'blah\' contains \'oil&blah\'blah\' && \'oil & blah\'blah\' contains \'oil blah\'s\'
\'oil & blah\'blah\' contains \'oil&blah\'blah\'||||||||||\'oil & blah\'blah\' contains \'oil blah\'s\' '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end