import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|{2,}|&{2,}|((?:(?!&&|\\|\\||\\bcontains\\b).)*) (contains) ((?:(?!&&|\\|\\||\\bcontains\\b).)*)";
final String string = "'oil & blah'blah' contains 'oil&blah'blah' && 'oil & blah'blah' contains 'oil blah's' \n"
+ "'oil & blah'blah' contains 'oil&blah'blah'||||||||||'oil & blah'blah' contains 'oil blah's' ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}