re = /^(I[VX]|VI{0,3}|I{1,3})|((X[LC]|LX{0,3}|X{1,3})(I[VX]|V?I{0,3}))|((C[DM]|DC{0,3}|C{1,3})(X[LC]|L?X{0,3})(I[VX]|V?I{0,3}))|(M+(C[DM]|D?C{0,3})(X[LC]|L?X{0,3})(I[VX]|V?I{0,3}))$/m
str = 'I
II
III
IV
V
VI
VII
VIII
IX
X
XI
XII
XIII
XIV
XV
XVI
XVII
XVIII
XIX
XX
XLIV
XLIX
LXXIX
XCIV
XCIX
C
CI
CII
CIII
CIV
CVI
CIX
CD
CM
CC
CCC
D
DC
DCC
DCCC
CX
CXX
CXIX
CMXCIX
MCMXLIV
MMMMCCCXII
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end