use strict;
my $str = 'START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end ()END
START OF THE SHOW with some gibberish characters () also lots of non-sense things () with boring end ()END
START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end (III)END
START OF THE SHOW with some gibberish characters (1) also lots of non-sense things (2) with boring end (3)END
START OF THE SHOW with some gibberish characters (111) also lots of non-sense things (222) with boring end (333)END';
my $regex = qr/^(.*?)(?!(?:\(.?\)))END$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}