re = /^(.*?)(?!(?:\(.?\)))END$/m
str = 'START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end ()END
START OF THE SHOW with some gibberish characters () also lots of non-sense things () with boring end ()END
START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end (III)END
START OF THE SHOW with some gibberish characters (1) also lots of non-sense things (2) with boring end (3)END
START OF THE SHOW with some gibberish characters (111) also lots of non-sense things (222) with boring end (333)END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end