import re
regex = re.compile(r"^(.*?)(?!(?:\(.?\)))END$", flags=re.MULTILINE)
test_str = ("START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end ()END\n\n"
"START OF THE SHOW with some gibberish characters () also lots of non-sense things () with boring end ()END\n\n"
"START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end (III)END\n\n"
"START OF THE SHOW with some gibberish characters (1) also lots of non-sense things (2) with boring end (3)END\n\n"
"START OF THE SHOW with some gibberish characters (111) also lots of non-sense things (222) with boring end (333)END")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")