#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\+\d[\d\s]{6,}"
Local $sString = "+31 65 406 10 73" & @CRLF & _
"Ik ben een creatieve technicus, werkzaam in de engineering. Ik werk als zelfstandige en ben een netwerk aan het aanleggen om samen remote te werken." & @CRLF & _
"De engineeringswereld is vrij conservatief en ik zie kansen in de nieuwe manier van werken, remote en internationaal. Dit wil ik graag uitbouwen naar een groter geheel. Ik werk nu eigenlijk als ZZP'er voor bedrijven, maar ik wil zelf opdrachten aannemen en samen met mijn netwerk uitwerken. Dit is voor mij een switch van freelancer naar ondernemer. Dit is een grote stap en ik kan wel wat hulp gebruiken in hoe ik mijn merk kan opbouwen." & @CRLF & _
"een stukje duidelijkheid wat mijn aanpak kan zijn, weten hoe jullie werken en of we mogelijk een match zijn." & @CRLF & _
"ik ben net begonnen, gaat nu richting 10k, maar is nog niet stabiel" & @CRLF & _
"op dit moment nog geen budget, op relatief korte termijn hoop ik wel budget beschikbaar te hebben" & @CRLF & _
"www.linkedin.com/in/front-lastname-b57665222"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")