const regex = /\+\d[\d\s]{6,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+\\d[\\d\\s]{6,}', 'gm')
const str = `+31 65 406 10 73
Ik ben een creatieve technicus, werkzaam in de engineering. Ik werk als zelfstandige en ben een netwerk aan het aanleggen om samen remote te werken.
De engineeringswereld is vrij conservatief en ik zie kansen in de nieuwe manier van werken, remote en internationaal. Dit wil ik graag uitbouwen naar een groter geheel. Ik werk nu eigenlijk als ZZP'er voor bedrijven, maar ik wil zelf opdrachten aannemen en samen met mijn netwerk uitwerken. Dit is voor mij een switch van freelancer naar ondernemer. Dit is een grote stap en ik kan wel wat hulp gebruiken in hoe ik mijn merk kan opbouwen.
een stukje duidelijkheid wat mijn aanpak kan zijn, weten hoe jullie werken en of we mogelijk een match zijn.
ik ben net begonnen, gaat nu richting 10k, maar is nog niet stabiel
op dit moment nog geen budget, op relatief korte termijn hoop ik wel budget beschikbaar te hebben
www.linkedin.com/in/front-lastname-b57665222`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}