// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\+\d[\d\s]{6,}").unwrap();
let string = "+31 65 406 10 73
Ik ben een creatieve technicus, werkzaam in de engineering. Ik werk als zelfstandige en ben een netwerk aan het aanleggen om samen remote te werken.
De engineeringswereld is vrij conservatief en ik zie kansen in de nieuwe manier van werken, remote en internationaal. Dit wil ik graag uitbouwen naar een groter geheel. Ik werk nu eigenlijk als ZZP'er voor bedrijven, maar ik wil zelf opdrachten aannemen en samen met mijn netwerk uitwerken. Dit is voor mij een switch van freelancer naar ondernemer. Dit is een grote stap en ik kan wel wat hulp gebruiken in hoe ik mijn merk kan opbouwen.
een stukje duidelijkheid wat mijn aanpak kan zijn, weten hoe jullie werken en of we mogelijk een match zijn.
ik ben net begonnen, gaat nu richting 10k, maar is nog niet stabiel
op dit moment nog geen budget, op relatief korte termijn hoop ik wel budget beschikbaar te hebben
www.linkedin.com/in/front-lastname-b57665222";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}