using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\B\w)(?:\[three]|\(one\)|\.two\.)(?<!\w\B)";
string input = @"[three] (one) .two. One[three]more time(one)here we.two.have a text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}