re = /(?!\B\w)(?:\[three]|\(one\)|\.two\.)(?<!\w\B)/m
str = '[three] (one) .two. One[three]more time(one)here we.two.have a text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end