$re = '/(?!\B\w)(?:\[three]|\(one\)|\.two\.)(?<!\w\B)/m';
$str = '[three] (one) .two. One[three]more time(one)here we.two.have a text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);