#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)test2(?:\n.*test[234])*?\n.*test4"
Local $sString = " 1 test1" & @CRLF & _
" 2 test2" & @CRLF & _
" 5 test5" & @CRLF & _
" 6 test1" & @CRLF & _
" 7 test2" & @CRLF & _
" 8 test3" & @CRLF & _
" 9 test4" & @CRLF & _
" 10 test5" & @CRLF & _
" 11 test1" & @CRLF & _
" 12 test2" & @CRLF & _
" 13 test3" & @CRLF & _
" 14 test4" & @CRLF & _
" 15 test5" & @CRLF & _
"" & @CRLF & _
" 1 test1" & @CRLF & _
" 2 test2" & @CRLF & _
" 5 test5" & @CRLF & _
" 6 test1" & @CRLF & _
" 7 test2" & @CRLF & _
" 8 test3" & @CRLF & _
" 9 test4" & @CRLF & _
" 10 test5" & @CRLF & _
" 11 test1" & @CRLF & _
" 12 test2" & @CRLF & _
" 13 test3" & @CRLF & _
" 14 test4" & @CRLF & _
" 14 test4" & @CRLF & _
" 14 test4" & @CRLF & _
" 15 test5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")