import Foundation
let pattern = #"test2(?:\n.*test[234])*?\n.*test4"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 test1
2 test2
5 test5
6 test1
7 test2
8 test3
9 test4
10 test5
11 test1
12 test2
13 test3
14 test4
15 test5
1 test1
2 test2
5 test5
6 test1
7 test2
8 test3
9 test4
10 test5
11 test1
12 test2
13 test3
14 test4
14 test4
14 test4
15 test5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)