# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*down_([^_]+).*/\1/gm;t' <<< "down_PK56c-t_S5_L001.clones_IGH"