const regex = new RegExp('^from\\s+
(?P<package_name>[.\\w]+)\\s+
import\\s+
(\\()?
(?(2)
(?P<object>[^()]+)\\)
|
(?P<object2>(?:.+[\\n\\r]?)+)
)', 'gm')
const str = `from .sql.base import (
SchemaVisitor
)
import os # ignore this import
from _pytest.config import (
main, UsageError, cmdline,
hookspec, hookimpl
)
I can capture this with:
syntax1 = re.compile(r'^ *from (?P<package>[.\\w]+) +import +\\(?(?P<objects>[*, \\n\\w]+)\\)? *\$',
flags=re.MULTILINE)
Syntax #2 uses line continutation (if needed), and technically has no newlines within the import statement:
from pandas import Series
from .solvers import solve, solve_linear_system, solve_linear_system_LU, \\
solve_undetermined_coeffs, nsolve, solve_linear, checksol, \\
det_quick, inv_quick, check_assumptions
from .ode import checkodesol, classify_ode, dsolve, \\
homogeneous_order`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}