use strict;
my $str = 'from .sql.base import (
SchemaVisitor
)
import os # ignore this import
from _pytest.config import (
main, UsageError, cmdline,
hookspec, hookimpl
)
I can capture this with:
syntax1 = re.compile(r\'^ *from (?P<package>[.\\w]+) +import +\\(?(?P<objects>[*, \\n\\w]+)\\)? *$\',
flags=re.MULTILINE)
Syntax #2 uses line continutation (if needed), and technically has no newlines within the import statement:
from pandas import Series
from .solvers import solve, solve_linear_system, solve_linear_system_LU, \\
solve_undetermined_coeffs, nsolve, solve_linear, checksol, \\
det_quick, inv_quick, check_assumptions
from .ode import checkodesol, classify_ode, dsolve, \\
homogeneous_order';
my $regex = qr/^from\s+
(?P<package_name>[.\w]+)\s+
import\s+
(\()?
(?(2)
(?P<object>[^()]+)\)
|
(?P<object2>(?:.+[\n\r]?)+)
)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}