$re = '/([^\s\d]+\s+[^\s\d]+) (\d+)/m';
$str = ' 2012-15-08 07:05 *** Error importing row no. 5: The import of 785 line failed because of 345 item';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);