import re
regex = re.compile(r"([^\s\d]+\s+[^\s\d]+) (\d+)", flags=re.MULTILINE)
test_str = " 2012-15-08 07:05 *** Error importing row no. 5: The import of 785 line failed because of 345 item"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")