package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).*\bdiscover\b.*`)
var str = `this has discover in it
discover
discover
looks like a discovery
Discover
ends with discover
something discovery something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}